Skip to main content
UVM Libraries Research Guides banner

Zotero User's Guide

Mac System Requirements & Downloads

In order for the current version of Zotero (3.0.8) to run properly on the Mac and you will need the following:

Operating System: OS X 10.6 or higher

Firefox: 4.X or higher

Microsoft Word: 2008 or higher

Before Installing: You will also need to allow pop-ups from Zotero.org in your browser. Download and install each item on the list before going to the next.

Windows System Requirements & Downloads

In order for the current version of Zotero (3.0.8) to run properly on a Windows based computer and you will need the following:

Operating System: Windows 2000 or newer

Firefox: 4.X

Microsoft Word: Word 2000 or later - not Word 2010 starter edition

Before Installing: You will also need to allow pop-ups from Zotero.org in your browser. Download and install each item on the list before going to the next.